Dialer & Communication Disruption
Incident Report for CINC
Resolved
This issue has been resolved. Thank you for your patience while we awaited the confirmation.
Posted Apr 15, 2021 - 17:27 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 15, 2021 - 16:22 EDT
Investigating
Some users may experience degraded performance with the CINC communication tools, including disruption to the dialer. We are working with our provider for frequent updates. Please continue to monitor the status page for additional updates.
Posted Apr 15, 2021 - 15:38 EDT
This incident affected: Agent Dashboard, Switchboard Sarah and Email (Email - Processor).