Network Congestion Causing Delays/Issues with Text and Cell Communications
Incident Report for CINC
Resolved
This incident has been resolved by out third party provider.
Posted Apr 15, 2020 - 12:35 EDT
Update
We are continuing to investigate this issue.
Posted Apr 08, 2020 - 16:21 EDT
Investigating
As of April 8th, 2020 - we were made aware of a congestion issue affecting our third-party provider for calls, text messages, and text notifications. Carriers around the world are currently experiencing capacity issues because of the increased demands on their networks due to COVID-19. Most of the reports we've seen so far have primarily come from ATT Wireless, with very occasional reports coming in from Verizon Wireless.

The congestion issues typically begin around 9am EST - with the more affected times being each hour and a half mark during morning business hours.

We are monitoring the situation via updates provided from our third-party provider and will provide more information as it becomes available.
Posted Apr 08, 2020 - 10:10 EDT
This incident affected: Agent Dashboard, Switchboard Sarah and Mobile Apps (CINC for Agents).